Computer Stops Responding When You Specify Both the /SMARTCARD and the /SAVECRED Switches in the RUNAS Command (823872)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

When you try to use the runas secondary logon command together with both the /smartcard and the /savecred switches, the computer stops responding.

CAUSE

This problem occurs because of an access violation in the Secondary Logon service. This problem occurs when both the following conditions exist:
  • You type the runas command together with both the /smartcard and the /savecred switches.

    -and-
  • You do not specify other user credentials in the runas command.
For example, if you type a command that is similar to the following, the computer stops responding:

runas /smartcard /savecred cmd.exe

However, if you enter a command that is similar to the following, the command works as you expect:

runas /smartcard /savecred /user:user@contoso.com cmd.exe

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Microsoft Windows XP Service Pack 1 (SP1) to install this hotfix. For additional information about how to obtain the latest Windows XP service pack, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to Obtain the Latest Windows XP Service Pack

Restart requirement

You must restart your computer to apply the changes that are made by this hotfix. However, you do not have to restart your computer immediately after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP 32-Bit

Date         Time   Version           Size     File name
--------------------------------------------------------------
19-Aug-2003  18:58  5.1.2600.1261     158,720  Credui.dll

Windows XP 64-Bit

Date         Time   Version           Size     File name        Platform
-------------------------------------------------------------------------
19-Aug-2003  18:58  5.1.2600.1261     312,832  Credui.dll       IA-64
19-Aug-2003  18:58  5.1.2600.1261     158,720  Wcredui.dll      x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about how to use the secondary logon functionality in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

225035 Secondary Logon (Run As): Starting Programs and Tools in Local Administrative Context

For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB823872 kbAudITPRO kbAudEndUser