"EapType 26 Failed in RasEapMakeMessage and Returned 0x80004005" error message when you try to connect to a wireless network in Windows 2000 (823859)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you try to use a Microsoft Windows 2000-based computer to connect to a wireless network, you may receive the following error message:
ERROR: EapType 26 failed in RasEapMakeMessage and returned 0x80004005

CAUSE

This problem may occur if the Windows 2000 client cannot obtain an IP address.

Typically, you receive this error message when you try to connect to a wireless network that is running Internet Authentication Service (IAS) through a switch that is manufactured by Cisco Systems, Inc. When the connection is negotiated by using the Protected Extensible Authentication Protocol (PEAP), the computer does not respond to the seventh Extensible Authentication Protocol (EAP) packet, because the Cisco switch cannot forward the packet.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must have Microsoft Windows 2000 Service Pack 4 installed on your computer.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version             Size  File name
   ---------------------------------------------------------
   12-Aug-2004  17:29  5.0.2195.6968     61,200  Raschap.dll
   04-Jun-2004  23:13  5.0.2195.6935  5,887,488  Sp3res.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the new file naming schema for Microsoft Windows software update packages, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB823859 kbAudITPRO