Your Windows XP computer stops responding after you log on (823830)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

A computer that is running Microsoft Windows XP may stop responding when the "Applying local settings" message appears after you log on. When this problem occurs, you may experience any one of the following symptoms:
  • An error that references Svchost.exe may be logged in the Dr. Watson log file.
  • You may receive the following event message in the event viewer when you use the net use command: Event Type: Error
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7000
    Description: The messenger service failed to start due to the following error: The pipe state is invalid.
  • You cannot use the net use command to map a network drive after you start the computer. However, you can access remote shares through a UNC path.

CAUSE

This problem occurs when the Srvsvc.dll file generates an access violation error. This error stops the Svchost.exe process that loads services such as Workstation and Server. As a result, Winlogon.exe and other processes stop responding.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version        Size    File name
   -----------------------------------------------------
   08-Jul-2003  00:39  5.1.2600.1243  77,824  Srvsvc.dll       
  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB823830 kbAudITPRO