You Cannot Install Driver Files for Your Network Adapter and You Receive a "Cannot Install This Hardware" Error Message (823771)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you replace a defective network adapter in your computer with a later version of the same model network adapter, and then try to install the driver files for the new network adapter, you receive an error message similar to the following:
Cannot install this hardware. There was a problem installing this hardware. Network_Adapter_Model_Name. An error occurred in the installation of this device. The name is already in use as either a service name or a service display name.

CAUSE

This behavior may occur if the defective network adapter leaves entries in the registry when you remove it from your computer.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this behavior, follow these steps:
  1. Click Start, right-click My Computer, and then click Properties.
  2. Click the Hardware tab, and then click Device Manager.
  3. In Device Manager, expand Network adapters, right-click Network_Adapter_Name, and then click Uninstall.
  4. In the Confirm Device Removal dialog box, click OK.
  5. Repeat steps 3 and 4 for each network adapter that is listed in Device Manager.
  6. Close Device Manager.
  7. Click Start, click Run, type msconfig, and then click OK.
  8. On the General tab, click Diagnostic Startup - load basic devices and services only.
  9. Click the Services tab, and then click to select the Hide All Microsoft Services check box.
  10. In the Services list, click to clear each of the services check boxes, and then click OK.
  11. Restart your computer.
  12. Click Start, click Run, type regedit, and then click OK.
  13. In Registry Editor, click HKEY_LOCAL_MACHINE, click File, and then click Export.
  14. In the Save In list, click Desktop, in the Name box type HKEY_LOCAL_MACHINE, click Save, and then close the Export Registry File dialog box.
  15. Expand HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services, and then look for registry entries specific to your network adapter. For example, if you have a Linksys network adapter, look for entries named Linksys. When you find an entry, right-click the name and then click Delete.
  16. Click Start, click Run, type msconfig, and then click OK.
  17. On the General tab, click Normal Startup - load all device drivers and services.
  18. Click the Services tab, and then click to select each service check box.
  19. Restart your computer.
  20. Windows XP will detect your network adapter and install the correct driver files.
  21. Click Start, click Run, type msconfig, and then click OK.
  22. On the General tab, click Normal Startup - load all device drivers and services.
  23. Click the Services tab, and then click to select the Hide All Microsoft Services check box.
  24. In the Services list, click to select each of the services check boxes, and then click OK.
  25. Restart your computer several times to make sure that all devices and services are loading correctly.
  26. When you are sure that all devices are working correctly, right-click the following registry entry on your desktop, click Delete, and then click Yes to confirm: HKEY_LOCAL_MACHINE,
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:10/18/2003
Keywords:kbprb KB823771 kbAudEndUser