"The File RTL8139.sys on RealTek RTL8139/810x Family Fast Ethernet NIC Driver Disk" Error Message When You Upgrade to Windows XP Professional (823769)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

When you try to upgrade to Windows XP Professional on your Hewlett Packard (HP) Pavilion ZT-1000 laptop computer, you may receive the following error message:
The file RTL8139.sys on RealTek RTL8139/810x Family Fast Ethernet NIC driver disk is needed. Copy files from: c:\pnp\lan

CAUSE

This issue occurs because the Windows Installer program looks for the RTL8139.sys file in the wrong folder.

RESOLUTION

To resolve this issue, use one of the following methods:

Method 1: During Setup

  1. When you receive the error message that is mentioned in the "Symptoms" section of this article, click Browse.
  2. Locate and then click the following folder:

    C:\HP\Drivers\LAN

  3. Click OK.

Method 2: After Setup

If you completed the upgrade without installing the RealTek RTL8139/810x Family Fast Ethernet network adapter driver, follow these steps:
  1. Right-click My Computer, and then click Manage.
  2. Under Computer Management (local), click Device Manager.
  3. Expand Network Adapters, right-click your network adapter, and then click Update Driver.
  4. Click Install from a list or specified location (Advanced), and then click Next.
  5. Click Search for the best driver in these locations, click to select the Include this location in the search check box, and then click Browse.
  6. Locate the following folder:

    C:\HP\Drivers\LAN

  7. Click the C:\HP\Drivers\LAN folder, and then click OK.
  8. Follow the instructions on the screen to complete the driver installation.

MORE INFORMATION

For technical support with your HP Pavilion ZT-1000 laptop computer, contact HP. Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. For information about how to contact Hewlett Packard, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:8/14/2003
Keywords:kbprb KB823769 kbAudEndUser