FIX: Distributed Link Service (DLS) Connections May Stay in Pending State (823741)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2
  • Microsoft SNA Server 4.0 SP3
  • Microsoft SNA Server 4.0 SP4

SYMPTOMS

Branch-based SNA Server 4.0 and Host Integration Server 2000 servers that use a Distributed Link Service (DLS) to communicate with central-based servers may experience a condition where the host connection stays in a pending state and does not activate.

CAUSE

A Distributed Link Service can be configured to have multiple Primary Remote Link Services and multiple Alternate Remote Link Services. If the Distributed Link Service can connect to one of the Primary Remote Link Services, that primary remote link service will be used, even if a host connection cannot be activated over that remote link service. The result is that the host connection on the branch-based SNA Server 4.0 or Host Integration Server 2000 server stays in a pending state.

If this type of condition exists, the Distributed Link Service on the branch server will not fail over to the list of Alternate Remote Link Services to try to activate the host connection by using one of the alternate remote link services.

RESOLUTION

The section contains information about fixes for:
  • SNA Server 4.0
  • Host Integration Server 2000

SNA Server 4.0

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft SNA Server 4.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   -------------------------------------------------------
   16-Jul-2003  18:35  4.0.0.607    41,744  Snaremls.dll
				

Note Because of file dependencies, the most recent fix that contains the preceding files may also contain additional files.

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

328152 How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   -------------------------------------------------------
   18-Jul-2003  22:46  5.0.0.927    49,424  Snaremls.dll
				

Note Because of file dependencies, the most recent fix that contains the preceding files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

MORE INFORMATION

A Distributed Link Service uses a priority list for the remote link services that are listed in its configuration:
  • Services in the Primary Remote Link Services field are considered priority 0.
  • Services in the Alternate Remote Link Services field are considered priority 1.
When a Distributed Link Service (for example, SnaRem1) is started, it sends an OPEN LINK REQUEST message that initiates the process of locating a remote link service to use for the host connection. The Distributed Link Service always starts by trying a priority 0 (that is, a Primary) remote link service. If there are multiple priority 0 remote link services, one is chosen at random. If the Distributed Link Service can connect to the selected remote link service at the network protocol (TCP/IP) level, the OPEN LINK REQUEST completes successfully. This successful network protocol level connection indicates that the remote link service (for example, SnaDlc1) is running on the central SNA Server 4.0 or on the Host Integration Server 2000 server.

The problem that is described in this article occurs if the actual SNA connection from the either central SNA Server 4.0 or from the Host Integration Server 2000 server cannot be successfully activated.

The following scenario demonstrates the problem that is described in this article:
  1. A branch-based Host Integration Server 2000 server uses a Distributed Link Service that is configured as follows:

    Primary Remote Link Services - \\central1\Snadlc1
    Alternate Remote Link Services - \\Central2\snadlc2
  2. The central-based Host Integration Server 2000 servers have two network adapters:
    • One network adapter uses TCP/IP for communication with the branch-based servers.
    • The other network adapter uses Data Link Control (DLC) to communicate with the host system.
  3. Under typical operating conditions, the Distributed Link Service on the branch-based Host Integration Server 2000 server connects to \\Central1\Snadlc1.
  4. If the network connection between the central-based server that is named CENTRAL1 and the host system becomes unavailable, the Distributed Link Service on the branch-based server continues to try to use \\Central1\Snadlc1 for its host connection. At this point, the host connection is in a pending state and the Distributed Link Service continues to try to activate the connection by means of \\Central1\Snadlc1. The Distributed Link Service will not fail over to the alternate remote link service that is configured.

    Note You can simulate the network unavailable condition by disconnecting the network adapter that is using DLC from the network or by disabling the network adapter in the operating system.
The Distributed Link Service will fail over to an alternate remote link service if it cannot connect any of the primary remote link services at the network protocol level. If the primary remote link services are stopped (for example, by using the net stop SnaDlc1 command) on the central-based servers, or if the network connection between the branch-based server and the central-based server cannot be established, the Distributed Link Service will fail over to the list of alternate remote link services.

The design of the Distributed Link Service does not guarantee that the host connection will be successfully activated. It only verifies that the remote link service is running and that it can be connected to at the network protocol level (as described in the numbered scenario earlier in this section).

The following conditions can result in a DLS connecting to a remote link service without getting an active host connection:
  • The network connection between the central-based server(s) and the host system is not available.
  • The host system, such as the front end processor (FEP), does not respond to either the test command or to the xid (Exchange Identifier) command (or both).
  • The physical unit (PU) is not active on the IBM mainframe.
  • The host application(s) are not active on the IBM mainframe.
After you apply the update that is provided in this article, the Distributed Link Service tries to find a primary remote link service that can activate the host connection. If none of the primary remote link services can activate the host connection, the Distributed Link Service will fail over to the alternate remote link services.

The successful activation of the host connection is defined as the successful activation of the physical SNA link. For DLC/802.2 connections, this includes the successful exchange of test and xid commands and the receipt of the sabme (Set Asynchronous Balanced Mode Extended) command from the remote device (for example, IBM 3745 Front End Processor). After a remote link service is found that activates the host connection, the Distributed Link Service will reset its search algorithm so that the primary remote link services are tried first when the current host connection is closed and a new connection attempt is initiated.

The new search algorithm can still result in the use of a remote link service that does not provide active host sessions for the end users.

This update addresses only the issue where the SNA link between the central server and the host system cannot be established.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbQFE kbfix kbbug KB823741 kbAudDeveloper