Active Directory Migration Tool Version 2 Uses the DNS Name to Resolve the IP Address (823735)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

When you use Active Directory Migration Tool (ADMT) version 2 to migrate computer objects from a Microsoft Windows 2000 Server-based server to a Microsoft Windows Server 2003-based server, the Domain Name System (DNS) name of each computer object is used to resolve the IP address instead of the NetBIOS name, as expected. When you experience this problem, you may receive the following error messages:
Status: Install Failed
The RPC server is unavailable.
The following information may be logged in the dispatch log:
2004-08-17 14:03:35 ERR2:7625
Unable to connect to \\workstation.ad.microsoft.com\ADMIN$. The machine might be down or its Server, Netlogon service might not be started. rc=1722
The RPC server is unavailable.

CAUSE

If the dNSHostName attribute is defined on the computer object, the DNS name is used to resolve the IP address of the computer object. If the dNSHostName is not defined, the NetBIOS name is used to resolve the IP address. By default, all Windows 2000-and-later workstations have this attribute defined on the Active Directory computer object.

WORKAROUND

To work around this issue, clear the dNSHostName attribute from the computer accounts before you use ADMT to migrate your computer objects from a Windows 2000-based server to a Windows Server 2003-based server.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Restart Requirement

You must restart your computer after you apply this hotfix.

Prerequisites

No prerequisites are required.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------------
   29-Jul-2003  16:55  5.2.3790.72       111,104  Mcsdispatcher.exe  
   10-Jul-2003  18:00                        271  Branches.inf
   29-Jul-2003  17:28                     10,095  Kb823735.cat
   29-Jul-2003  16:57                        354  Updatebr.inf
   29-Jul-2003  16:57                      5,003  Update_rtmqfe.inf
Note To install this hotfix on Windows 2000-based computers or on Windows XP-based computers that are running ADMT 2.0, extract the hotfix by using the /x switch. Next, copy Mcsdispatcher.exe to the ADMT install directory. For example, copy Mcsdispatcher.exe to C:\Program Files\Active Directory Migration Tool.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB823735 kbAudITPRO