Event ID 327 Is Logged and You Receive a Non-Delivery Receipt After an Extended Period of Time (823494)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you try to send an e-mail message, you receive a non-delivery receipt (NDR) after an extended period of time has passed. For example, you receive an NDR two days after you sent the e-mail message.

The NDR that you receive is similar to the following message: Your message did not reach some or all of the intended recipients.
Subject: Subject
Sent: Date_and_Time
The following recipient(s) could not be reached:
User_Name on Date_and_Time
The e-mail system was unable to deliver the message, but did not report a specific reason. Check the address and try again. If it still fails, contact your system administrator.
<WholeNumber.circuitz.vashisth.com #5.0.0>

When you view the Application log in Event Viewer on your Exchange 2003 server, you see that the following event is logged every five minutes:Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Exchange Store Driver
Event ID: 327
Computer: Computer_Name
Description:
The following call : EcGetMime to the store failed. Error code : -2147024809. MDB : 87354ede-8a7b-4a27-8778-2e7b84422acd. FID : 1-123. MID : 1-1918B1D. File : .

CAUSE

This problem may occur if an e-mail message is stuck in the local delivery queue. An e-mail message may become stuck in the local queue if the message content becomes corrupted during the content conversion from MAPI to MIME. MIME conversion fails if there is some data in the message that the IMAIL component cannot map to MIME.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem described in this article. Only apply it to systems that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Exchange Server 2003 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. Component: MDB

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   --------------------------------------------------
   31-Jul-2003  18:19  6.5.6980.15        49,152  Mdbevent.dll     
   31-Jul-2003  18:21  6.5.6980.15        24,064  Mdbrole.dll
   31-Jul-2003  19:58  6.5.6980.15        13,312  Mdbtask.dll
   31-Jul-2003  19:57  6.5.6980.15     5,030,400  Store.exe
				

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/3/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbbug KB823494 kbAudITPRO