Add Printer Wizard does not complete the installation of your printer (823447)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When you use the Add Printer Wizard to add a printer to your computer, the printer installation may stop and may not complete.

CAUSE

This problem may occur if you select Yes to print a test page in the Print Test Page dialog box of the Add Printer Wizard. The printer installation does not continue until you click OK in the Printer_Name on Server_Name dialog box, but the Add Printer Wizard window hides this dialog box.

RESOLUTION

Windows XP service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Windows Server 2003 and Windows XP hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 or Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this fix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003
   Date         Time   Version           Size  File name          Platform
   -----------------------------------------------------------------------
   16-Jul-2003  21:41  5.2.3790.66    549,376  Printui.dll          X86
   10-Jul-2003  18:00                     271  Branches.inf         X86
   16-Jul-2003  23:49                  10,091  Kb823447.cat         X86
   16-Jul-2003  21:43                     354  Updatebr.inf         X86
   16-Jul-2003  21:43                   5,105  Update_rtmqfe.inf    X86
   16-Jul-2003  21:42  5.2.3790.66  1,142,272  Printui.dll        IA-64
   16-Jul-2003  21:41  5.2.3790.66    549,376  Wprintui.dll         X86
   10-Jul-2003  17:58                     271  Branches.inf       IA-64
   16-Jul-2003  23:48                  10,444  Kb823447.cat       IA-64
   16-Jul-2003  21:45                     354  Updatebr.inf       IA-64
   16-Jul-2003  21:45                   5,375  Update_rtmqfe.inf  IA-64
Windows XP
   Date         Time   Version             Size  File name     Platform
   ---------------------------------------------------------------------
   27-Jun-2003  03:07  5.1.2600.1221     80,896  Ntprint.dll     X86
   27-Jun-2003  03:07  5.1.2600.1239    529,920  Printui.dll     X86
   24-Jun-2003  02:54  5.1.2600.1239    690,688  Xpsp2res.dll    X86
   27-Jun-2003  03:07  5.1.2600.1221    248,832  Ntprint.dll   IA-64
   27-Jun-2003  03:07  5.1.2600.1239  1,256,960  Printui.dll   IA-64
   12-May-2003  04:41  5.1.2600.1221     80,896  Wntprint.dll    X86
   24-Jun-2003  03:14  5.1.2600.1239    529,920  Wprintui.dll    X86
   24-Jun-2003  02:54  5.1.2600.1239    690,688  Wxpsp2res.dll   X86
   24-Jun-2003  02:54  5.1.2600.1239    690,176  Xpsp2res.dll  IA-64

Windows 2000 hotfix information


A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this fix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version             Size  File name    Platform
   -------------------------------------------------------------------
   24-Jun-2003  16:54  5.0.2195.6745     66,320  Ntprint.dll  X86
   24-Jun-2003  16:54  5.0.2195.6761    381,712  Printui.dll  X86
   17-Jun-2003  17:54  5.0.2195.6756  4,576,768  Sp3res.dll   X86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbWinXPpreSP2fix kbWinServ2003preSP1fix kbBug kbfix kbQFE kbWin2000preSP5fix KB823447 kbAudEndUser kbAudITPRO