Several Remote Access Service Error Events Appear After You Upgrade to Windows 2000 Service Pack 4 (823405)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Professional SP4



SYMPTOMS

After you upgrade your computer to Windows 2000 Service Pack 4 (SP4), you may experience all the following symptoms:
  • The following events appear in the system log of the Event Viewer: Source: RemoteAccess
    Category: None
    Event ID: 20071
    Date: date
    Time: time
    Type: Error
    User: N/A
    Computer: ComputerName
    Description: The Point to Point Protocol module C:\WINNT\System32\rastls.dll returned an error while initializing. The network request is not supported.

    -and-

    Source: RemoteAccess
    Category: None
    Event ID: 20151
    Date: date
    Time: time
    Type: Error
    User: N/A
    Computer: ComputerName
    Description: The Control Protocol EAP in the Point to Point Protocol module C:\WINNT\System32\rasppp.dll returned an error while initializing. The network request is not supported.

    -and-

    Source: Rasman
    Category: None
    Event ID: 20063
    Date: date
    Time: time
    Type: Error
    User: N/A
    Computer: ComputerName
    Description: Remote Access Connection Manager failed to start because the Point to Point Protocol failed to initialize. The network request is not supported.

    -and-

    Source: Service Control Manager
    Category: None
    Event ID: 7023
    Date: date
    Time: time
    Type: Error
    User: N/A
    Computer: ComputerName
    Description: The Remote Access Connection Manager service terminated with the following error: The network request is not supported.
  • The following event appears in the application log of the Event Viewer:Source: rasctrs
    Category: None
    Event ID: 2001
    Date: date
    Time: time
    Type: Error
    User: N/A
    Computer: ComputerName
    Description: The description for Event ID (2001) in Source (rasctrs) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: The event log file is corrupt.
  • If you try to create a new dial-up connection, some of the options are unavailable (appear dimmed).

CAUSE

This problem occurs if both of the following conditions exist:
  • You upgrade a Windows 2000 Service Pack 3 (SP3)-based computer to Windows 2000 SP4.
  • You have not configured the Routing and Remote Access service or a remote access dial-up connection on the computer that you upgrade to Windows 2000 SP4.

WORKAROUND

To work around this problem, restart the computer. When you restart the computer, all the remote access binary files are brought up to date.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When you install Windows 2000 SP4 on a Windows 2000 SP3-based computer that does not have the Routing and Remote Access service or the remote access dial-up connections configured, some of the remote access-related binary files are immediately replaced. Specifically, when Setup installs support for 802.1X, the initialization of these new binary files and the mismatch between the new and old binary files causes the events that are described in the "Symptoms" section of this article to appear in Windows 2000 Event Viewer. (Note that support for 802.1X is new in SP4.) This also causes some dial-up connection options to be unavailable. You must restart the computer before these updated files can be used. This issue does not occur when you install SP4 on a Windows 2000 SP3-based computer that has the Routing and Remote Access service or remote access connections configured. In this case, none of the remote access binary files are replaced until the computer is restarted because the files are in use.

Modification Type:MinorLast Reviewed:7/27/2003
Keywords:kbpending kbBug kbprb KB823405 kbAudITPRO