SharePoint Portal Server Intermittently Stops Responding When You Check In or Publish a Document (823388)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

SYMPTOMS

You may find that SharePoint Portal Server may intermittently stop responding. For example, SharePoint Portal Server may stop responding when you connect to the dashboard site and check in or publish a document to the Document Library, or when you back up SharePoint Portal Server.

CAUSE

This problem may occur in situations where the search component acquires a read lock in the same thread two times, and a thread that is no longer required is not released. This causes a deadlock condition and as a result, SharePoint Portal Server stops responding.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you have installed SharePoint Portal Server 2001 Service Pack 3 or a later service pack, you do not have to apply the hotfix.

Service pack information

This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

312963 How to obtain the latest SharePoint Portal Server 2001 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The P1 version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Prerequisites

Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 2 (SP2) or Microsoft SharePoint Portal Server 2001 Service Pack 2a (SP2a).

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version         Size       File name
---------------------------------------------------------
31-Jul-2003  07:56  10.145.6011.27  1,716,224  Mssrch.dll   

WORKAROUND

To work around this problem, shut down the server, and then restart it.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbSharePtPortalSvr2001SP3fix kbQFE kbSharePtPortalSvr2001preSP2fix kbfix kbbug KB823388 kbAudITPRO