"You Do Not Have Permission to Perform This Operation" Error Message When You Try to Check Out a Document From the Document Library (823365)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001
  • Microsoft SharePoint Portal Server 2001 SP2

SYMPTOMS

When you try to check out a document that is in the Document Library of your SharePoint Portal Server dashboard site by using Microsoft Internet Explorer, you may receive the following error message:
You do not have permission to perform this operation.
You do not experience these symptoms when you use Web folders to connect to SharePoint Portal Server, and then check out the document.

CAUSE

This problem occurs when the offline cache files are written to a folder on the server other than the folder that is specified in the following Microsoft OLE DB Provider for Internet Publishing (Msdaipp.dll) registry value:

HKEY_CLASSES_ROOT\Software\Microsoft\MasterAggregatorForIPP\MSDAIPP\ServerCacheLocation

For example, this problem occurs if the offline cache files are written to the folder that contains the profile of the last user who logged on to the server, even though the ServerCacheLocation registry value is set to the following location:

C:\Documents and Settings\ALL Users\Application data\Microsoft\MSDAIPP\Offline\

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you have installed SharePoint Portal Server 2001 Service Pack 3 or a later service pack, you do not have to apply the hotfix.

Service pack information

This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

312963 How to obtain the latest SharePoint Portal Server 2001 service pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   --------------------------------------------------
  24-Jun-2003  14:27  10.145.6011.23  1,187,840  Msdaipp.dll    
				
Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 2 and Microsoft SharePoint Portal Server 2001 Service Pack 2a.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbSharePtPortalSvr2001SP3fix kbQFE kbSharePtPortalSvr2001preSP2fix kbfix kbbug KB823365 kbAudITPRO