"Setup Cannot Locate a Qualifying Global Catalog Server" Error Message When You Try to Start the Information Store Service (823163)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you try to start the information store service on your Exchange Server 2003 computer, the information store may not start, and then you may receive the following error message:
The component "Microsoft Exchange Messaging and Collaboration Service" cannot be assigned the action "Install" because: -Setup cannot locate a qualifying Global Catalog server to connect to. Please run setup with the "/DomainPrep" switch in at least one domain that contains a Global Catalog server that belongs to the local or an adjacent Windows site.
Additionally, the following events may appear in the event logs.

System log:
Event Type: Error
Event Source: Service Control Manager
Event ID: 7024
Computer: Server1
Description: The Microsoft Exchange Information Store service terminated with service-specific error 0.

Application log :
Event Type: Error
Event Source: MSExchangeDSAccess
Event ID: 2069
Computer: Server1
Description: Process Store.exe (PID=3216). Dsaccess could not find any global catalog servers in the enterprise. Promote one or more of your domain controllers to a global catalog to allow dsaccess to function properly. For more information, click http://search.support.microsoft.com/search/?adv=1.

Event Type: Error
Event Source: MSExchangeIS
Event ID: 1121
Computer: Server1
Description: Error 0xfaf connecting to the Microsoft Active Directory. For more information, click http://search.support.microsoft.com/search/?adv=1.

Event Type: Error
Event Source: MSExchangeIS
Event ID: 5000
Computer: Server1
Description: Unable to initialize the Microsoft Exchange Information Store service. Error 0xfaf. For more information, click http://search.support.microsoft.com/search/?adv=1.

CAUSE

This issue may occur if one or both of the following conditions are true:
  • There is no global catalog in the forest.
  • There is a problem with the connection to the global catalog.

RESOLUTION

To resolve this issue, verify that there is at least one global catalog in the forest, and then verify the connection to the global catalog. If you do not have a global catalog in the forest, follow these steps on the domain controller that is to be used as the global catalog server:
  1. Start the Active Directory Sites and Services snap-in. To do so, click Start, point to Programs, point to Administrative Tools, and then click Active Directory Sites and Services.
  2. In the console tree, expand Sites, expand Default First Site Name, expand Servers, and then expand the domain controller that you want to configure as the global catalog server.
  3. Right-click NTDS Settings, and then click Properties.
  4. Click to select the Global Catalog check box, and then click OK.
  5. Restart the server.

    Note The first domain controller that is installed in a forest is the default global catalog server.

REFERENCES

For additional information about global catalog servers, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816105 HOW TO: Create or Move a Global Catalog in Windows Server 2003

313994 HOW TO: Create or Move a Global Catalog in Windows 2000

317209 How to Identify your Global Catalog Server Using Outlook 2000 and Outlook 2002

319206 OL2002: How to Specify the Closest or Specific Global Catalog Server


Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kberrmsg kbprb KB823163 kbAudITPRO