Majority node set clusters stop running on your Windows Server 2003-based network (823147)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition

SYMPTOMS

The majority node set clusters on your Microsoft Windows Server 2003-based network may stop running. Additionally, you cannot restart the majority node set clusters in this scenario.

CAUSE

This problem may occur if the quorum in a majority node set cluster becomes unsynchronized. In a majority node set cluster, data is replicated between all nodes of the cluster in a synchronous fashion. The shares on each majority node set cluster are kept synchronized by the Crs.log file. The Crs.log file is located in the root of each majority node set cluster. Every time that a share is changed, the operation that modifies the share is logged in the Crs.log file. Majority node set cluster shares remain synchronized by comparing the transactions that are logged in their respective Crs.log files with the Crs.log file of each of the other majority node set cluster shares.

The problem occurs when the Crs.log files of two majority node set clusters report that two cluster shares are synchronized, but a file is actually missing from one of the shares. This problem cannot be resolved if the cluster Crs.log files have grown sufficiently large that they wrap back to the beginning of the file and therefore write over the point where the inconsistency occurred. When a synchronization error occurs, the code that executes the majority node set resource may enter an infinite loop. This looping situation may cause the cluster to stop running, and then the cluster will not start again.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 64-bit editions
   Date         Time   Version            Size    File name	Platform
   ---------------------------------------------------------------------
   07-Jul-2003  23:31  5.2.3790.68     1,068,032  Clusres.dll      IA-64
   27-Jun-2003  23:29                        271  Branches.inf
   08-Jul-2003  00:00                     10,091  Kb823147.cat
   07-Jul-2003  23:35                        354  Updatebr.inf
   07-Jul-2003  23:35                      5,518  Update_rtmqfe.inf
Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name	Platform
   ---------------------------------------------------------------------
   07-Jul-2003  23:29  5.2.3790.68       446,976  Clusres.dll	x86      
   27-Jun-2003  23:30                        271  Branches.inf
   08-Jul-2003  00:01                     10,091  Kb823147.cat
   07-Jul-2003  23:33                        354  Updatebr.inf
   07-Jul-2003  23:33                      5,934  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbClustering kbBug kbfix kbQFE kbWinServ2003preSP1fix KB823147 kbAudITPRO