Extra CRLF Character Is Added to a POST Request That Is Sent to an HTTP 1.1 Server (823099)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • the operating system: Microsoft Windows 98
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows XP

SYMPTOMS

When a POST request is sent to a HTTP 1.1 server, Internet Explorer may append an extra carriage return and line feed character (CRLF) to the end of the post. This may cause problems with the server. The network may stop responding (hang) or you may receive a "Page Not Found" error message, depending on how the server or the Web application is configured.

Note If you suspect that you have this problem, follow the steps in the "Steps to Reproduce the Problem" section to test the problem. If you have this problem, apply the fix that is listed in the "Resolution" section.

CAUSE

This problem occurs because Internet Explorer may incorrectly store gzip compressed pages with the HTTP 1.0 header. If that page is later requested by Internet Explorer, it will read the 1.0 header and it will think that it should send an extra CRLF (in a subsequent POST request). Internet Explorer typically sends an extra CRLF in a POST request when it thinks that it is communicating with an HTTP 1.0-based server.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 6 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   26-Jun-2003  16:07  6.0.2800.1220  483,840  Urlmon.dll
				

WORKAROUND

To work around this problem, change the SendExtraCRLF setting in the registry. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type Regedit, and then click OK.
  3. Locate, and then click the following key in the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

  4. On the Edit menu, point to New, and then click DWORD Value.
  5. Type SendExtraCRLF, and then press ENTER.
  6. With SendExtraCRLF selected, click Modify on the Edit menu.
  7. In the Value data box, type 0, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Steps to Reproduce the Problem

  1. Create a test page containing a form. For example, type the following HTML code in Notepad:
     
    <html>
    <body>
    <a href="test.htm">Test</a>
    <br>
    <form action="bogus.asp" method="post">
    <input type="text" name="val1">
    <input type="submit">
    </form>
    </body>
    </html>
     
  2. On the File menu, click Save to save the test form on your Internet Information Server (IIS) with HTTP compression turned on.
  3. Start a Network Monitor trace.
  4. Locate your test form.
  5. Locate test form again using the link.
  6. Submit the form to perform a post operation. The destination URL does not exist and you will receive an error. This is expected.
  7. Stop the Network Monitor trace.
  8. Look in the Network Monitor trace.
Result: The POST operation should contain an extra CRLF in the post data even though the connection is with an HTTP 1.1 server. There should also be a GET request for the test form the second time and it should have responded with Not Modified (or the GET for the test form for the second occurrence may not even exist).

Modification Type:MinorLast Reviewed:11/1/2005
Keywords:kbHotfixServer kbQFE kbQFE kbIE600sp2fix kbIE600preSP2fix kbfix kbbug KB823099 kbAudEndUser