You receive a "Disk in drive <X> is not formatted" error message when you try to access an SD or MMC drive (823084)



The information in this article applies to:

  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4

SYMPTOMS

On a Windows 2000-based computer with a Secure Digital (SD) card or a MultiMedia Card (MMC) in the card reader, you may receive the following error message when you try to access the SD card or the MMC drive:
Disk in drive X is not formatted
You receive this error message after you put the computer in standby and you switch the SD card or the MMC in the reader with another card. When you resume the computer and you try to access the SD card or the MMC drive, you receive the error message. The problem occurs only if you try to access the drive within 15 to 20 seconds after you log on. This problem does not occur if you replace a Compact Flash (CF) card while the computer is in standby.

Additionally, the following error message may be logged in the Application event log:Event Type: Error
Event Source: Removable Storage
Event Category: None
Event ID: 17
Description: RSM cannot manage library Disk Name. It encountered an unspecified error. This can be caused by a number of problems including, but not limited to, database corruption, failure communicating with the library, or insufficient system resources.

CAUSE

This issue is caused by a code problem in the Disk.sys disk driver. Windows 2000 includes an optimization for handling IOCTL_DISK_GET_PARTITION_INFO operations in the Disk.sys driver. This optimization does not re-enumerate a device every time that the partition information is requested. This method works well for non-removable hard disks, but does not work as well for removable disks that can be replaced with different media while the computer is in standby or hibernate. If a removable medium is replaced while the computer is in standby or hibernate, no media change notification is received by Windows. This causes Windows to read from the same boot sector number on the new disk as was used on the previous disk.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   -------------------------------------------------------
   14-Apr-2003  20:53  5.0.2195.6736  35,856  Classpnp.sys
   19-Jun-2003  22:17  5.0.2195.6759  30,800  Disk.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbQFE kbStorageDev kbDDK kbBug kbfix kbWin2000preSP5fix KB823084 kbAudDeveloper kbAudEndUser kbAudOEM