You Cannot Mount the Information Store Database After an Online Restore (823016)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

When you perform an online restore of the Exchange Server 2003 information store, you may not be able to mount the database, and one or more of the following event IDs may be logged in the application event log: Event Type: Warning
Event Source: ESE
Event Category: Logging/Recovery
Event ID: 457
Date: 5/15/2001
Time: 3:52:56 PM
User: N/A
Computer: SERVERNAME
Description: Information Store (3368) The log signature of the existing logfile E00.log doesn't match the logfiles from the backup set. Logfile replay cannot succeed unless all signatures match. Event Type: Error
Event Source: ESE BACKUP
Event Category: Callback
Event ID: 904
Date: 5/15/2001
Time: 3:52:56 PM
User: N/A
Computer: SERVERNAME
Description: Information Store (3368) Callback function call ErrESECBRestoreComplete ended with error 0xC8000262. Event Type: Error
Event Source: ESE BACKUP
Event Category: Recovery
Event ID: 903
Date: 5/15/2001
Time: 3:52:56 PM
User: N/A
Computer: SERVERNAME
Description: Information Store (3368) Restore from directory q:\tmp1\SG01 ended with error (Error returned from an ESE function call (-610).
If you try to mount the information store database from Exchange System Manager, you may receive the following error message:
An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.

CAUSE

This issue may occur if the Exchange Information Store service (Store.exe) is not running when you restore a full online backup of an Exchange Server 2003 computer. The restore process tries to replay the transaction log files, but because the Exchange Information Store service is not running, this prevents the information store databases from mounting.

RESOLUTION

To resolve this issue, follow these steps:
  1. Back up the current state of information store by using the NTBackup utility. Back up both the database and the logs, even if the information store is corrupted.
    1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Backup.
    2. In the Welcome to the Windows 2000 Backup and Recovery Tools dialog box, click the Backup tab, and then expand the Microsoft Exchange tree. Select any or all Exchange Server computers in the organization that you want to back up.

      Note You cannot select a box that appears unavailable; you must double-click Microsoft Exchange or expand the Exchange Server tree. You can expand the tree down to the folder or down to the information store for any server.
    3. Verify that the files in the Backup media or file name box are the files that you want to back up, and then click Start Backup.
    4. Verify the information in the Backup Job Information dialog box, and then click Start Backup.
    5. Verify that the backup completed successfully, and then click Close.
  2. Stop the Exchange Information Store service.
    1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
    2. Right-click Microsoft Exchange Information Store, and then click Stop.
    3. Make sure that the service stops successfully.
  3. Delete all files (database files and log files) in the DRIVE:\Program Files\Exchsrvr\Mdbdata folder, where DRIVE is the drive that Exchange is installed on. Or, move these files to another location.
  4. Restart the Exchange Information Store service.
    1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
    2. Right-click Microsoft Exchange Information Store, and then click Start.
    3. Make sure that the service starts successfully.
  5. Delete all files that are created by the information store in the DRIVE:\Program Files\Exchsrvr\Mdbdata folder when it tries to mount the database.
  6. Perform the restore:
    1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Backup.
    2. In the Welcome to the Windows 2000 Backup and Recovery Tools dialog box, click the Restore tab.
    3. Click to select the check boxes next to the files that you just backed up, and then click Start Restore.
    4. In the Restoring Database Store dialog box, verify that the correct Exchange server is listed in the Restore To box, and then type the location where the log files are restored to. For example, type DRIVE:\Program Files\Exchsrvr\Mdbdata, click to select the Last Backup Set check box, click to select the Mount Database After Restore check box, and then click OK.
    5. In the Enter Backup File Name dialog box, select the file that you just backed up in the Restore from backup file box, and then click OK.
    6. Verify that the restore completed successfully, and then click Close.
  7. Verify that the Exchange Information Store service is running:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
    2. Locate the Exchange information store, and then verify that the status is set to Started.

REFERENCES

For more information about Exchange Server 2003, visit the following Microsoft Web sites:

Modification Type:MinorLast Reviewed:11/4/2005
Keywords:kbprb KB823016 kbAudITPRO