User cannot create a Terminal Server roaming profile path if a user with the same name has logged on from another domain (821929)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you configure the Set path for TS Roaming Profiles Group Policy setting, this setting does not work as expected. Specifically, if two users with the same user name in different domains log on to a Microsoft Windows Server 2003-based terminal server, they cannot access their Terminal Server roaming profiles.

CAUSE

This problem occurs when both of the following conditions are true:
  • Users with the same user name are hosted in different domains.
  • One of those users has logged on to the terminal server and has created a roaming profile.
For example, in a scenario where the following users exist

username1@example.com
username1@domain.example.com

if username1@example.com logs on to the terminal server, a roaming profile that is named "username1" is created. When username1@domain.example.com logs on, username1@domain.example.com cannot access the existing username1 profile. After you install this hotfix, each user receives a unique profile name with a format of username.domain.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer to apply the changes after you install this hotfix. However, you do not have to restart the computer immediately after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 32-Bit Editions

   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   14-Jul-2003  21:58  5.2.3790.68       538,624  Winlogon.exe   

Windows Server 2003 64-Bit Edition

   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   11-Jul-2003  19:39  5.2.3790.68       635,904  Winlogon.exe     IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

After you install this hotfix, Windows determines the location of the user's home directory by using the following logic when a user logs on:
  1. Try to locate the ...\UserName.Domain path. If it exists and the user has full control permissions configured in the folder, this path is used for the home directory.
  2. If ...\UserName.Domain is not accessible or does not exist, then try to access ...\UserName.
  3. If ...\UserName exists and the user has Full Control permissions to it, this path is used for the home directory.
  4. If ...\UserName is not accessible, then use ....\UserName.Domain.
For more information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates


Modification Type:MinorLast Reviewed:7/5/2006
Keywords:kbHotfixServer kbenv kbBug kbfix kbQFE kbWinServ2003preSP1fix KB821929 kbAudITPRO