You Receive a "Page Cannot Be Displayed" Error Message When You Post to a Site That Requires Authentication (821814)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows 98
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows Server 2003

SYMPTOMS

Internet Explorer may not post data from a POST request and you may receive a "Page cannot be displayed" error message. This problem may occur if the following conditions exist:
  • You perform the POST request on a new connection with a target page that requires authentication.
  • The server immediately replies to the POST request with a "401 Access Denied" response and closes the connection.

CAUSE

The server closes the connection without reading the whole request body, and the server resets the connection when it receives frames that involve the entity body for the POST request. Because the connection is reset, Internet Explorer (Wininet.dll) cannot read the "401 Access Denied" response and process it.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer 6 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   27-May-2003  14:57  6.0.2800.1204  586,752  Wininet.dll

WORKAROUND

You might be able to work around this problem by making sure to use the POST request on an already authenticated connection. You can do this, for example, by sending a GET request before you send the POST request.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The hotfix that this article describes implements a code change in Wininet.dll to:
  • Detect the RESET condition on a POST request.
  • Save the data that is to be posted.
  • Retry the POST request with the content length set to 0. This prevents the reset from occurring and permits the authentication process to complete.
  • Retry the original POST request.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbIE600preSP2fix kbfix kbBug KB821814