Generic Host Process Error Message and a Flashlight Icon Appear (821690)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

When you start your computer, you may receive the following error message:
Generic Host Process for WIN32 Services has encountered a problem and needs to close. We are sorry for the inconvenience.
If you click Click Here at the bottom of the message box, the following error signature information may appear:
App name    App version   Module name   Module version   Offset
---------------------------------------------------------------------
Svchost.exe 5.1.2600.0    Hpgtpusd.dll  1.1.0.56         00008d0d
When you click Start, and then click My Computer, or when you double-click My Computer on your Windows desktop, Windows may search, and a flashlight icon may appear, for a long time (for example, five minutes) before files appear. A list of files and folders may not appear.

CAUSE

This behavior may occur if use an old HP printer driver or an old HP scanner driver.

RESOLUTION

To resolve this problem, follow these steps:
  1. Turn off the computer and the printer or the scanner.
  2. Disconnect the printer or the scanner from the computer.
  3. Restart the computer.
  4. Install the compatible drivers and software for the printer or the scanner, and then reconnect the printer or the scanner to the computer.
Contact HP to obtain compatible drivers for the printer or scanner. For information about how to contact HP, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products. Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

MORE INFORMATION

For additional information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:

819017 Long Delay Before Files Appear in My Computer in Windows XP

REFERENCES


Modification Type:MinorLast Reviewed:11/4/2003
Keywords:kbprb kberrmsg KB821690 kbAudEndUser