SMS: Conv20.exe May Cause Clients to Be Marked as Not Installed (821647)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4
  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

Although a Systems Management Server (SMS) client is a fully installed client, that client may be shown in the SMS Administrator console as not being installed. When you view the client in an SMS Administrator console collection, the Client column may contain "No" instead of containing "Yes." Also, the Client column value may change periodically between "Yes" and "No." If you have created a collection in which the member list criteria include the "Client" property, SMS clients may unexpectedly drop out of the collection.

CAUSE

This problem may occur if you have multiple SMS sites in a hierarchy, and you have run a version of the Conv20.exe tool earlier than version 2.0.1493.4207 on one of the child sites.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Systems Management Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix for SMS 2.0 Service Pack 4 (SP4) sites has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name   Platform
   ------------------------------------------------------------------
   01-May-2002  22:40  2.0.1493.4207  1,356,672  Conv20.exe  x86
   31-May-2003  21:13                       541  Update.sql  x86
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

Using the Hotfix Installer

Note This method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the Sms2.0-kb821647-spX-x86-enu.exe hotfix file (where X is the service pack version) and the platform folders to the new folder. The folder structure must be such that the update file is located one folder "above" the platform folders.
  3. From each of the primary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console if it is running.
  5. Run Sms2.0-kb821647-spX-x86-enu.exe, and then follow the instructions in the wizard.

Performing a Manual Installation

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the platform folders that contain the hotfix files to the folder that you created.
  3. From each of the primary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console if it is running.
  5. Stop all SMS services.
  6. Load the Update.sql script by using a SQL query tool such as Query Analyzer or ISQL/W.
  7. In the SQL query tool, click the SMS database, and then run the script.
  8. Restart the SMS services.

WORKAROUND

To work around this problem, follow these steps:
  1. From each of the primary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  2. Quit the SMS Administrator console if it is running.
  3. Stop all SMS services.
  4. Start a SQL query tool such as Query Analyzer or ISQL/W.
  5. In the SQL query tool, click the SMS database, and then run the following command:

    IF EXISTS (SELECT * FROM syscolumns WHERE name = 'Client0' and cdefault > 0) EXEC sp_unbindefault 'System_DISC.Client0'

  6. Restart the SMS services.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When SMS Network Discovery or SMS Server Discovery (Site System Discovery) discovers a resource and creates a discovery data record (DDR), the DDR does not include the "Client" property. This is expected behavior. When Data Discovery Manager later processes the DDR and adds the discovery data to the System_DISC SQL table, SQL adds a null value to the Client0 column because Data Discovery Manager does not include any data for this column. Note that SQL adds this default value only if the DDR is for a new system that is not already contained in the System_DISC table.

If you ran a version of Conv20.exe earlier than 2.0.1493.4207 on the site server, SQL adds a 0 to the Client0 column for new systems. This flags the associated system as not being an SMS client. In this case, SQL adds a 0 instead of a null value because earlier versions of Conv20.exe set the Client0 column definition in the System_DISC table to dbo.SMSDefaultZero (this translates to 0).

When the DDR data is replicated to the parent SMS site, the DDR has the "Client" property set to 0. When the DDR is processed on the parent site or sites further up the hierarchy, the existing Client0 value in the database is incorrectly set by the replicated DDR to 0. The next time that the client generates a heartbeat DDR, the Client value is changed from "No" (0) to "Yes" (1) again.

Note that running the new version of Conv20.exe does not correct this problem on an affected site. However, the new version of Conv20.exe is installed as SmsRootFolder\Logs\Q821647\Conv20.exe in case you need the tool later. Run the Update.sql script to correct the problem as described earlier in this article.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP6fix kbfix kbBug KB821647