You receive an error message if you use backup in Windows 2000 or Windows XP to catalog or restore a tape made in Windows Server 2003 (821588)



The information in this article applies to:

  • Microsoft Windows XP 64-Bit Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

SYMPTOMS

If you use the Backup program (Ntbackup.exe) in Windows 2000 or Windows XP to restore or to catalog a tape backup that was created by using Microsoft Windows Server 2003, you may receive the following error message:
Backup Device Error

CAUSE

The Backup program in Windows Server 2003 can allocate and read tape block sizes up to 64 kilobytes (KB). However, the Backup program in Windows 2000 and Windows XP can allocate and read tape block sizes only up to 32 KB. Therefore, the Backup program in Windows 2000 and Windows XP cannot restore a tape that uses block sizes that are larger than 32 KB. The Backup program in Windows Server 2003 can restore tapes with block sizes up to 64 KB.

RESOLUTION

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP Home Edition SP1, Windows XP Professional SP1, Windows XP Tablet PC Edition, Windows XP Media Center Edition
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-Aug-2003  06:05  5.1.2600.1254   1,135,104  Ntbackup.exe     
Windows XP 64-Bit Edition Version 2002
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-Aug-2003  07:08  5.1.2600.1254   3,471,360  Ntbackup.exe     IA-64

Windows 2000

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-May-2003  16:24  5.0.2195.6748   1,164,048  Ntbackup.exe     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This problem does not occur with third-party backup programs.

Modification Type:MinorLast Reviewed:11/2/2005
Keywords:kbHotfixServer kbQFE kbpending kbbug KB821588