The End-User Defined Character (EUDC) Font Is Not Displayed Correctly in WordPad (821576)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP4

Notice

SYMPTOMS

When you use WordPad to view a document that contains an end-user defined character (EUDC) font, the font is not displayed correctly in WordPad.

CAUSE

This behavior may occur if you configure WordPad to start automatically when you log on to the computer.

RESOLUTION

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version         Size    File name      Platform
-------------------------------------------------------------------
22-May-2003  21:40  5.1.2600.1225   63,488  Userinit.exe   IA-64
22-May-2003  21:40  5.1.2600.1225   22,016  Wuserinit.exe  x86
22-May-2003  21:40  5.1.2600.1225   22,016  Userinit.exe   x86
21-Mar-2003  23:55  5.3.16.5        59,904  Xpsp1hfm.exe   IA-64
10-Jun-2003  23:31  5.1.2600.115    62,976  Userinit.exe   IA-64
10-Jun-2003  23:31  5.1.2600.115    21,504  Wuserinit.exe  x86
10-Jun-2003  01:39  5.1.2600.1232   63,488  Userinit.exe   IA-64
10-Jun-2003  01:38  5.1.2600.1232   22,016  Wuserinit.exe  x86
11-May-2003  23:26  5.3.16.6        24,576  Xpsp1hfm.exe   x86
10-Jun-2003  23:31  5.1.2600.115    21,504  Userinit.exe   x86
10-Jun-2003  01:38  5.1.2600.1232   22,016  Userinit.exe   x86

Note Because of file dependencies, this update requires Windows XP Service Pack 1 (SP1).

Windows 2000

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
-----------------------------------------------------------
02-Jul-2003  18:09  5.0.2195.6738      42,256  Basesrv.dll 
17-Jan-2003  16:06  5.0.2195.6656     236,304  Cmd.exe     
02-Jul-2003  18:09  5.0.2195.6762     222,992  Gdi32.dll   
02-Jul-2003  18:09  5.0.2195.6741     711,440  Kernel32.dll
02-Jul-2003  18:09  5.0.2195.6751     333,072  Msgina.dll  
08-Apr-2003  05:54  5.0.2195.6701      90,232  Rdpwd.sys
27-Jun-2003  00:27  5.0.2195.6761   4,607,488  Sp3res.dll  
02-Jul-2003  18:09  5.0.2195.6766     380,176  User32.dll  
02-Jul-2003  18:09  5.0.2195.6745     385,808  Userenv.dll 
01-Jul-2003  16:35  5.0.2195.6766      17,680  Userinit.exe
19-Jun-2003  22:08  5.0.2195.6759   1,628,784  Win32k.sys
01-Jul-2003  00:56  5.0.2195.6765     182,032  Winlogon.exe
02-Jul-2003  18:09  5.0.2195.6758     243,984  Winsrv.dll  
02-Jul-2003  18:09  5.0.2195.6741     711,440  Kernel32.dll
02-Jul-2003  18:10  5.0.2195.6759   1,628,784  Win32k.sys
02-Jul-2003  18:09  5.0.2195.6758     243,984  Winsrv.dll  

Note Because of file dependencies, this update requires Windows 2000 Service Pack 4 (SP4).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Windows XP This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWin2000preSP5fix kbWinXPpreSP2fix kbfix kbbug KB821576 kbAudITPRO kbAudEndUser