Performance Counter Instance Appears Several Times When You Combine Log Files by Using Relog.exe (821541)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

After you run the Relog.exe command to append one or more .blg log files to an existing performance monitoring log file, when you view the log file information, extra counters appear for the same instances in the Performance tool. For example, before you run the Relog.exe command to combine log files, the Add Counters dialog box for the Process performance object is similar to the following:
Select counters from listSelect instances from list
% Processor Timesvchost#1
svchost#2
However, after you run the Relog.exe command, the Add Counters dialog box is similar to the following:
Select counters from listSelect instances from list
% Processor Timesvchost#1
svchost#1#1
svchost#2
svchost#2#1
You expect the same instances from different log files to be combined and to be listed as a single instance.

CAUSE

This problem occurs when both of the following conditions are true:
  • You append one or more .blg log files to an existing performance monitoring log file.
  • The performance counter instances end with the number sign (#) index.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-Bit Editions
   Date         Time   Version      Size     File name
   ----------------------------------------------------
   23-Jul-2003  21:55  5.2.3790.71  282,112  Pdh.dll
Windows Server 2003, 64-Bit Edition
   Date         Time   Version      Size     File name  Platform
   --------------------------------------------------------------
   23-Jul-2003  21:58  5.2.3790.71  747,008  Pdh.dll    IA-64
   23-Jul-2003  21:55  5.2.3790.71  282,112  Wpdh.dll   x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB821541 kbAudITPRO