Only Operations That Are Performed by Administrators Are Logged to the W3wp<ApplicationPoolName>.log File (821512)



The information in this article applies to:

  • Microsoft Windows SharePoint Services

SYMPTOMS

When you set the following registry value to turn on full diagnostic logging for Windows SharePoint Services, only operations that are performed by administrators may be logged to the following log file:

HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Web Server Extensions\6.0\LogLevel=9

The log file does not contain any entries for operations that are performed by users who do not have administrator credentials.

CAUSE

This issue occurs because operations that are performed by users who do not have administrative credentials are not logged to the log file. Impersonation is neither suspended nor resumed when full diagnostic logging is turned on or turned off.

WORKAROUND

To work around this issue, assign users Read and Write permissions to the log file. The log file is named W3wpApplicationPoolName.log, where ApplicationPoolName is the name of the application pool name, and is located in the Drive:\Windows\Temp folder, where Drive is the drive where Windows is installed. To assign users Read and Write permissions to the log file:
  1. Start Windows Explorer, and then locate the following folder: Drive:\Windows\Temp folder.
  2. Right-click the W3wpApplicationPoolName.log file, and then click Properties.
  3. Click the Security tab.
  4. Click Add.
  5. In the Select Users or Groups dialog box, add the users and groups that you want, and then click OK.
  6. In the Group or user names list, click the user or group that you added.
  7. In the Permissions for UserOrGroupName list, click to select the Allow check box next to Read, click to select the Allow check box next to Write, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For more information about Windows SharePoint Services, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbnofix kbBug KB821512 kbAudITPRO