SYMPTOMS
When you search for clips in a Microsoft Office document (on the
Insert menu, point to
Picture, and then click
Clip Art) during a Microsoft Windows 2000 Terminal Services session, you may receive the following error message:
Microsoft Clip Organizer
Not enough memory. Try closing other applications or restarting the computer.
Not enough storage is available to complete this operation.
Error Code 0x8007000E
No clips are returned in the search results, even though Clip Organizer contains clips that match your search criteria. As a result, you cannot insert a clip into your Office document.
CAUSE
This issue may occur if both of the following conditions are true:
- You connect to a Windows 2000 Service Pack 4 (SP4)-based computer by running Windows 2000 Terminal Services from a Terminal Services client.
-and- - You log on to the terminal server as a user who is not a member of the Administrators group.
This issue occurs because of changes in security settings made to Terminal Services in Windows 2000 SP4 that affect the functionality of the Interface Remoting component in Microsoft Data Access Components (MDAC). For more information about the new security settings that have been introduced in Windows 2000 SP4, see the "More Information" section of this article.
RESOLUTION
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.
To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
----------------------------------------------------
20-Jun-2003 18:54 2.53.6203.0 192,784 Msdaps.dll
Note If you are running MDAC version 2.7 Service Pack 1 (SP1) on a Windows 2000 SP4-based computer, contact PSS to obtain an MDAC 2.7 SP1 version of this hotfix.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
-----------------------------------------------------
16-Jul-2003 15:13 2.71.9031.52 188,416 Msdaps.dll
MDAC version 2.8 also resolves this problem. For information about how to download and install MDAC version 2.8, visit the following Microsoft web site: