Messages that are sent through an X.400 connector may remain in the outgoing X.400 queue (821177)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

When users send outgoing messages through an X.400 connector, those messages may remain in the outgoing X.400 protocol queue. The messages are not delivered. If you remove the first message from the queue, messages may be delivered successfully but may then again become stuck in the outgoing queue.

CAUSE

This problem occurs when a user who sends a message has an X.400 proxy address that contains a given name, but that does not contain a surname. An X.400 proxy address that contains a given name, but that does not contain a surname, is unsupported by Microsoft Exchange 2000 Server because this is not a valid X.400 address. Because this is an invalid X.400 address, Exchange 2000 Server should return the message to the sender as undeliverable, but it does not.

RESOLUTION

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824282 September 2003 Exchange 2000 Server post-Service Pack 3 rollup

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange 2000 Server service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Component: MTA

Date         Time   Version            Size    File name
-----------------------------------------------------------
14-Jun-2003  02:23  6.0.6476.0      1,798,144  Emsmta.exe
14-Jun-2003  02:14  6.0.6476.0         40,960  X400omv1.dll

Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

After you install this update, Exchange 2000 Server generates a non-delivery report (NDR) when it receives a message from a recipient who has an invalid X.400 proxy address (as described in the "Cause" section of this article). You must correct the X.400 proxy address for each user who has an invalid address.

WORKAROUND

To work around this problem, manually remove the message that is stuck from the X.400 remote delivery queue, and then make sure that the there is a valid surname in the user's X.400 proxy address.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:1/26/2006
Keywords:kbHotfixServer kbQFE kbfix kbExchange2000preSP4fix kbbug KB821177 kbAudITPRO