UDDI Services Installation Fails on Computers That Use a Turkish System Locale (821170)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you try to install Universal Description, Discovery, and Integration (UDDI) Services on a computer that uses a Turkish system locale, the installation does not complete successfully.

CAUSE

This problem occurs because the Setup program misinterprets the lowercase and the uppercase letter "i" in the Turkish language. This causes a problem in the UDDI Services installation because several SQL scripts that are used during setup declare an entityTypeID variable, but entityTypeid is used instead. Because of the way Setup interprets the "i," SQL misinterprets entityTypeid as a new, undeclared variable, and then throws an error.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size       File name
   ------------------------------------------------------
   21-Oct-2003  21:57  6.0.4039.0  1,148,416  Acuddi.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/5/2005
Keywords:kbBug kbfix kbQFE kbWinServ2003preSP1fix KB821170 kbAudITPRO