Windows Explorer Stops Responding When You Click an XML File (821164)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • Microsoft Windows 2000 Professional
    • Microsoft Windows 2000 Server

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you enable the Thumbnail view on your Microsoft Windows 2000-based computer, and then you open a folder that contains XML files, Windows Explorer stops responding (hangs) when you click an XML file.

CAUSE

This issue occurs if you have Microsoft Internet Explorer 6.0 Service Pack 1 (SP1) installed. XML thumbnail rendering does not work correctly on a Windows 2000-based computer with Internet Explorer 6.0 SP1 installed.

WORKAROUND

To work around this issue, disable XML thumbnail rendering. To do this, follow these steps. Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Copy the following text to a Notepad document:

    Windows Registry Editor Version 5.00
    
     
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.xml\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
    
    @=-
    
     
    
    

    Note To start Notepad, click Start, point to Programs, point to Accessories, and then click Notepad.
  2. Save the Notepad file as a .reg file on your hard disk. To do this, follow these steps:
    1. On the File menu in Notepad, click Save As.
    2. In the Save as type list, click All Files.
    3. In the File name box, type XML.reg, and then click Save.
  3. Locate the XML.reg file that you just saved, and then double-click it to import the new .reg file into the registry.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:10/27/2003
Keywords:kbnofix kbBug KB821164 kbAudITPRO