Mapped Network Drives Are Not Released When Cluster Drives Are Brought Back Online (820952)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

When you try to access information on a mapped network drive that is located on a node that has been brought back online (after a failure), you may not be able to do so.

CAUSE

This issue occurs when you try to access the information either by using My Computer or by using a command prompt. In this scenario, the Disk Management snap-in and the Cluster Administrator tool report that the disk is online.

This issue may occur if both of the following conditions are true:
  • You map a drive by using a drive letter that is already in use by a cluster physical disk resource.

    -and-
  • The group that contains that resource subsequently fails over to the node that contains the mapped drive.
This issue occurs because of changes in the way that object space management is handled in Microsoft Windows Server 2003. For more information about these changes in Windows Server 2003, and about how to define an MS-DOS device name, visit the following Microsoft Web site:

WORKAROUND

To work around this issue, use both of the following methods:
  • Do not use a drive letter that is already in use by a cluster disk resource for mapped drives.

    -and-
  • Disconnect the mapped network drive that is using the cluster shared drive. The cluster disk information is now accessible, but until you restart the computer, the icon for the mapped drive in My Computer indicates that this drive is still a network drive.
Note When the issue that is described in the "Symptoms" section occurs, clustered programs on the disk continue to work correctly. Clustered programs connect to the disk by using the correct drive letter instead of the mapped drive that is displayed in My Computer.

Modification Type:MajorLast Reviewed:4/5/2004
Keywords:kbprb KB820952