Exchange Server 2003 performance counters are not seen in Windows Management Instrumentation (820847)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you start a Microsoft Windows Management Instrumentation-based monitoring program on a Microsoft Exchange Server 2003 computer, you may not see the results for the Exchange Server 2003 performance counters.

CAUSE

This problem occurs because Windows Management Instrumentation (WMI) uses AutoDiscovery/AutoPurge (ADAP) to build its internal performance counter table. If the Exchange Server 2003 services are not started when the WMI ADAP process is started, the performance counters are not transferred to WMI.

WORKAROUND

To work around this problem, you can run the wmiadap.exe /f command to force the transfer of all the performance libraries. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type wmiadap.exe /f, and then press ENTER.
  3. Type exit, and then press ENTER to close the command prompt.
  4. Start WMI.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To confirm that this problem is occurring, you can use the WbemTest.exe tool that is provided with Microsoft Windows Server 2003. To use the WbemTest.exe tool, follow these steps:
  1. Click Start, click Run, type Wbemtest, and then click OK.
  2. In Windows Management Instrumentation Tester, click Connect.
  3. In the Namespace box, type root\cimv2, and the click Connect.
  4. Click Enum Classes.
  5. In the Enter superclass name box, type Win32_Perf, click Recursive, and then click OK.
  6. In Query Results, you will not see results for the counters that are not transferred to WMI.
For example, the counter object for Exchange Server 2003 routing is OBJECT_SDSMTP_ROUTING_009_NAME=SMTP Routing. If this counter does not exist, you will not see the following lines in Query Results:
  • Win32_PerfFormattedData_SDSMTPROUTING_SMTPRouting
  • Win32_PerfRawData_SDSMTPROUTING_SMTPRouting

Modification Type:MinorLast Reviewed:11/10/2005
Keywords:kbprb KB820847 kbAudITPRO kbAudDeveloper