VDS service returns an error status of 8000ffff to all requests in Windows Server 2003 (820766)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

On your Microsoft Windows Server 2003-based computer, the Virtual Disk service (VDS) returns the following error message in response to any command line request:

swProvider->QueryPacks failed, hr=0x8000ffff (<invalid enum -- 0x8000ffff>)

CAUSE

This problem may occur when an instance of the class that represents information about a group of disks for a specific provider becomes corrupted.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name     Platform
   -----------------------------------------------------------------
   08-Jul-2003  23:55  5.2.3790.68  316,928  Vdsdyndr.dll  x86
   08-Jul-2003  23:59  5.2.3790.68  731,136  Vdsdyndr.dll  IA-64

WORKAROUND

To work around this problem, restart the VDS service.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

The VDS implements a single, uniform interface for managing disks. Each hardware vendor writes a VDS provider that translates general purpose VDS application programming interfaces (APIs) into specific instructions for that hardware vendor's hardware. With this abstraction layer that is provided by the VDS, Windows Server 2003 offers a more robust set of solutions, including greater flexibility for making long-term investment decisions about storage area networks (SANs) and about other storage options.

For additional information about Windows Server 2003 file services, click the following article number to view the article in the Microsoft Knowledge Base:

818703 White Paper: Technical Overview of Windows Server 2003 File Services

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB820766 kbAudITPRO