Computer intermittently stops responding and a Stop 0x000000C2 error occurs (820765)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

If you are using a computer that is running Microsoft Windows 2000, the computer may intermittently stop responding (crash) and the following Stop error may occur:
*** STOP 0x000000C2 BAD_POOL_CALLER

CAUSE

This problem may occur when you have NetBIOS transport enabled. In a bug that exists in Netbt.sys, a Unicode string is initialized to a static string and then freed inside the NbtReadSingleParameter function. The BAD_POOL_CALLER (C2) error indicates that the current thread is making a bad pool request. Typically, this request occurs at an incorrect interrupt request (IRQ) level, or it is caused by the freeing of a memory allocation that has already been freed.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This patch requires Windows 2000 Service Pack 2 (SP2), Windows 2000 Service Pack 3 (SP3) or Windows 2000 Service Pack 4 (SP4).

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size     File name 
   -------------------------------------------------------- 
   21-May-2003  18:48  5.0.2195.6747   163,568  Netbt.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB820765 kbAudITPRO