Single Instance Storage service temporary files are not deleted or grow in size when you perform a backup or a volume snapshot operation (820622)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

SYMPTOMS

When you perform a backup or a volume snapshot operation on a volume that is managed by the Microsoft Single Instance Storage service (SIS), one or more of the following conditions may occur:
  • Temporary files that are used in the backup or the snapshot operation may not be deleted after the backup or snapshot operation ends.
  • Temporary files may unexpectedly grow in size.
  • You may not be able to open certain volume files on the snapshot volume.

CAUSE

The SIS filter driver (Sis.sys) may not correctly lock or unlock the FSCTL_LOCK_VOLUME API. Therefore, some volume files are not locked or unlocked correctly.

RESOLUTION

Windows Server 2003 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Aug-2003  23:48  5.2.3790.77        78,336  Grovel.exe       
   12-Aug-2003  23:48  5.2.3790.77         4,608  Grovmsg.dll      
   12-Aug-2003  23:18  5.2.3790.77        65,536  Sis.sys


Windows Server 2003, 64-Bit Edition

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Aug-2003  23:18  5.2.3790.77       220,672  Grovel.exe       
   12-Aug-2003  23:47  5.2.3790.77         4,096  Grovmsg.dll      
   12-Aug-2003  23:17  5.2.3790.77       209,920  Sis.sys

Windows 2000 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows 2000 Service Pack 3

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows 2000

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Feb-2004  01:03  5.0.2195.6897      89,360  Grovel.exe       
   12-Feb-2004  01:03  5.0.2195.6897      64,624  Sis.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For additional information about the Single Instance Storage Filter, click the following article number to view the article in the Microsoft Knowledge Base:

299726 A description of the functions of the Single Instance Storage Filter and the Groveler service


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinServ2003preSP1fix kbBug kbfix kbQFE kbWin2000preSP5fix KB820622 kbAudITPRO