Resource Records That Are Dynamically Updated Are Marked As Tombstones (820612)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server

SYMPTOMS

When you have two DHCP servers that are running either Windows 2000 Server or Windows 2000 Advanced Server, if these servers have the same scope and if they perform dynamic updates for A resource records (Host) and PTR resource records (Pointer) for their clients, valid resource records may be marked as tombstones. A tombstone is a resource record whose IsDeleted property is set to True.

CAUSE

This problem may occur if the following conditions are true:
  • A client computer requests to renew its IP address from both DHCP servers.
  • One of the DHCP servers holds the lease for the IP address.
  • The other DHCP server does not hold the IP address lease.
  • The DHCP server that does not hold the lease is the first server to make the request from the DNS server to renew the IP address for a client.
When these conditions are true, the resource records for the client that is trying to renew its IP address are marked as tombstones.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows 2000 Service Pack 3 is installed

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-May-2003  13:00  5.0.2195.6749     235,280  Dhcpssvc.dll     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB820612 kbAudITPRO