Cannot Connect to a Printer or the Connection Is Slow from the Search Printer Dialog Box (820604)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When you use an "Entire Directory" query to search for printers that are published in Active Directory directory service, there may be a delay. In a trace of the network activity, you may discover that after the query finds the printer in the global catalog, the client tries to look up additional printer properties on the server. However, the client returns a referral because the properties are not in the global catalog. The query to the root domain controller may be slow. Following the referral also takes time.

If there is no network connectivity from the member to the forest root domain controllers, you cannot connect to the printer from the Search dialog box. You do not receive an error message. Instead, the wizard just does not continue.

CAUSE

This problem occurs because the object connection string contains the forest root domain name. The query to the global catalog returned the name, but the name must be stripped when the printer must be connected.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Jun-2003  18:17  5.0.2195.6759      41,744  Dsfolder.dll     
   20-Jun-2003  18:17  5.0.2195.6759     157,456  Dsquery.dll      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB820604 kbAudITPRO