Spooler Service Crashes When You Submit a Print Job and an Event ID 7031 Message Is Logged in the System Log (820550)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Server SP3

SYMPTOMS

When you send a print job to a network printer, the Print Spooler service on the server that hosts the printer may shut down unexpectedly. This behavior may occur if you select multiple copies in the print job and when you print using the RAW data type.

CAUSE

This problem may occur if an access violation occurs in the Print Spooler service. If the size of the print buffer is not sufficient, it must be reallocated. However, in the call to reallocate the buffer, the GetPrinterInfo function allocates a 0 byte buffer and an access violation occurs.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Windows 2000 Service Pack 3 (SP3) is required to install this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   11-Jun-2003  15:50  5.0.2195.6749  252,176  Localspl.dll
   11-Jun-2003  15:50  5.0.2195.6741   80,656  Spoolss.dll
   11-Jun-2003  15:50  5.0.2195.6681   97,040  Win32spl.dll
Currently, there are two versions of the hotfix available for download. One is labeled "Free I386", and the other is labeled "Free x86". The free x86 hotfix includes the latest versions of the files as listed in the fix. Do not download the free I386 version, or the hotfix may not install correctly, and you may receive the error messages that are mentioned in the Microsoft Knowledge Base article 822384. If you encounter this problem, you have the incorrect version, and you must obtain the free x86 version.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWin2000preSP5fix KB820550 kbAudITPRO