J50.Log Files Appear in the System32 Folder Instead of in the System32\Wins Folder (820434)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you use the Netsh command-line tool with the WINS context to administer a Windows Internet Naming Service (WINS) server, log files (J50.log or J50.chk) may start to accumulate in the %Systemroot%\System32 folder instead of in the %Systemroot%\System32\Wins folder. Although it is standard for these files to be found in the %Systemroot%\System32\Wins folder, they should not appear in any other folder.

CAUSE

This problem may occur if you use the defaultparams or the DBChange=0 commands with the Netsh tool. This problem occurs because these commands write the wrong default value for the LoggingOn parameter. Therefore, WINS stops logging, but the Jet database continues logging in the default location (the %Systemroot%\System32 folder).

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version        Size    File name
------------------------------------------------------
18-Jun-2003  15:43  5.0.2195.6757  239,376 Winsmon.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWin2000preSP4Fix kbfix kbbug KB820434 kbAudITPRO