Users May Receive a Timeout Error in the Web Browser Window When They Access a Custom ASPX Web Page To Perform a Task in SharePoint Portal Server (820289)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

SYMPTOMS

When you use Microsoft Visual Studio .NET to create a program for use in SharePoint Portal Server, and two or more users access the same ASPX Web page at the same time to run the program and perform a task in SharePoint Portal Server, you may find that only one of the users can connect to the server and perform the task as expected. The other user or users cannot connect to the server, and they receive a timeout error message in their Web browser window.

CAUSE

This problem may occur in situations where Microsoft OLE DB Provider for Internet Publishing (Msdaipp.dll) incorrectly processes an object and does not release it. As a result, the critical section is not released, and other threads are in a wait state.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you have installed SharePoint Portal Server 2001 Service Pack 3 or a later service pack, you do not have to apply the hotfix.

Service pack information

This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

312963 How to obtain the latest SharePoint Portal Server 2001 service pack

Hotfix information

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size       File name
----------------------------------------------------------
09-May-2003  18:26  10.145.6011.18  1,187,840  Msdaipp.dll      
				
Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 2 (SP2).

STATUS

Microsoft has confirmed that this is a problem in Microsoft SharePoint Portal Server 2001.
This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

MORE INFORMATION

For more information about creating custom programs and extensions to SharePoint Portal Server, see the SharePoint Portal Server Software Development Kit (SDK). To do so, visit the following Microsoft Web site:
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/spssdk/html/_welcome_to_tahoe.asp?frame=true

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbSharePtPortalSvr2001SP3fix kbQFE kbfix kbbug KB820289