"Microsoft Windows Has Detected Software That Is Not Completely Installed on Your Computer" Message When You Upgrade a Windows 2000 Server-Based Computer to Windows Server 2003 (820277)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you install Exchange Server 2003 on a Microsoft Windows 2000 Server-based computer, if you upgrade the Windows 2000-based computer to Microsoft Windows Server 2003, you receive the following message in the Report System Compatibility window: Existing software was not fully installed. To fix this problem, click Details. When you click Details, you receive the following error message:
Microsoft Windows has detected software that is not completely installed on your computer. Windows Setup cannot continue until you finish installing this software.

To finish the installation process for this software quit Windows Setup. Restart your computer, and then log back on again. After you log on, a program will start immediately; allow it to complete. Restart Windows Setup.

CAUSE

This behavior occurs if you do not restart the Windows 2000-based computer after you install Exchange Server 2003 and before you run Windows Server 2003 Setup to upgrade the computer to Windows Server 2003. In this situation, some temporary Setup files are not removed. These files prevent Windows Setup from continuing. These files are referenced in the following registry key:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations

RESOLUTION

To resolve this behavior:
  1. Quit Windows Server 2003 Setup, and then restart the computer.
  2. Log on to the computer.
  3. Restart Windows Server 2003 Setup.
Note This procedure is included in the error message that you receive after you click Details in the message that is described in the "Symptoms" section of this article.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:11/10/2005
Keywords:kbnofix kbBug KB820277