ISA Server Security Configuration Wizard Fails (820194)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000

SYMPTOMS

When you run the Internet Security and Acceleration (ISA) Server Security Configuration Wizard, you may receive the following error message:
The system security configuration application failed. For more information, view the log file, Securwiz.log, located in the ISA Server installation folder.
This error appears when you select one of the following options in the ISA Server Security Configuration Wizard:
  • Dedicated
  • Limited Services
  • Secure
You receive this error message almost immediately after you click Finish in the Security Configuration Wizard and before ISA Server starts to process the security templates, when ISA Server displays the following message: Please wait while ISA Server configures system security for this computer.When you look in the ISA Server installation folder, the Securwiz.log file does not exist.

CAUSE

Before the ISA Server Security Configuration Wizard creates the Securwiz.log file and just before it starts to apply the templates to secure the server that is running ISA Server, the wizard checks the local computer. In one instance, the wizard checks if ISA Server is installed on a Domain Controller or on an ordinary server. To determine this, ISA Server uses a public API in the operating system. This API requires that the Server Service be running on the ISA Server. If the Server Service is stopped, the API fails. This causes the ISA Server Security Configuration Wizard to fail.

RESOLUTION

To resolve this problem, follow these steps:
  1. Right-click the My Computer icon on the desktop, and then click Manage.
  2. In the left pane of the Computer Management window, expand the Services and Applications node, and then click Services.
  3. In the right pane of the Computer Management window, click Server.
  4. Click Start Service on the toolbar.
  5. Run the ISA Server Security Configuration Wizard.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:5/5/2003
Keywords:KB820194