Disks are displayed with an incorrect status of "Not Initialized" in Disk Management when you use an MSA 1000 SAN storage system in Windows Server 2003 (820127)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition

SYMPTOMS

Assume a scenario where you use a Modular SAN Array (MSA) 1000 storage system on a two-node cluster and where one node of the cluster owns the hard disks. When you view the hard disks on the other node of the cluster in Disk Management, the hard disks may not display the expected status settings of Unknown and Unreadable. Instead, these hard disks may display a status of Not Initialized, and the volume may display a status of Unallocated. This symptom is also known to occur on the EMC CLARiiON CX400 and the CX600 storage systems.

CAUSE

This problem occurs in situations where the ERROR_BUSY error code is not translated correctly to the disk status description of Unreadable in Disk Management.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date           Time   Version      Size     File name   
------------------------------------------------------
13-May-2003    11:40  5.2.3790.12  157,000  Vds.exe   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about deploying server clusters in a storage area network (SAN) environment, click the following article number to view the article in the Microsoft Knowledge Base:

818668 White paper: Microsoft Windows clustering: storage area networks


Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB820127 kbAudITPRO