When you use the Enterprise Device Setup tool to configure an Active Directory user in Mobile Information Server 2002, you may receive the "The user object in Active Directory could not be obtained" error message (820100)



The information in this article applies to:

  • Microsoft Mobile Information Server 2002

SYMPTOMS

When you use the Enterprise Device Setup tool to configure an Active Directory user in Microsoft Mobile Information Server 2002, you may receive the following error message:
The user object in Active Directory could not be obtained.
Automation error.
An invalid dn syntax has been specified. (0x80072032)

CAUSE

This problem may occur if the name of the new user that appears in the Full name box in Active Directory Users and Computers contains any one of the following characters:
  • A backslash (\)
  • An equal sign (=)
  • A slash mark (/)
  • A comma (,)
  • A number sign (#)
  • A semicolon (;)
  • A plus sign (+)
  • A less than sign (<)
  • A greater than sign (>)
  • A straight quotation mark (")
For example, this problem may occur if the following text appears in the Full name box in Active Directory Users and Computers:

Aaberg, Jesper

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-May-2003  07:55  1.5.837.15        352,344  Bulkprov.exe     
   07-Feb-2003  05:42  1.0.0.0            24,576  Miscustom.dll    
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbexchMOBILITY kberrmsg kbQFE kbfix kbbug KB820100 kbAudITPRO