Serial Device Stops Working After Installing New Serial Device (82545)
The information in this article applies to:
- Microsoft Windows for Workgroups 3.1
- Microsoft Windows for Workgroups 3.11
- Microsoft Windows 3.1
- Microsoft Windows 3.11
- Microsoft Windows 95
This article was previously published under Q82545 SYMPTOMS
After you install a new serial device in your computer, an existing serial
device may stop responding when you use the new device. For example, you
may experience problems with a serial mouse on COM1 after you install an
internal modem on COM3.
CAUSE
Serial ports COM1 and COM3 share a common interrupt request line (IRQ),
IRQ 4, and serial ports COM2 and COM4 share IRQ 3. Because COM1 and COM3
share the same IRQ, the two serial ports cannot be used simultaneously.
This behavior most often occurs when an internal modem is installed on
COM3 or COM4 with a serial mouse already installed on COM1 or COM2. When
you use the modem, the mouse stops responding (hangs). This is caused by
the modem taking control of the IRQ the mouse uses to communicate with the
computer.
RESOLUTION
To resolve this situation, remove the new serial device from your computer
to determine if the existing serial device regains its functionality. If
the remaining serial device functions correctly, reinstall the new serial
device, but configure the new device to use a different IRQ. For
information about how to configure the new serial device, consult the
documentation included with the new device, or contact the device's
manufacturer.
MORE INFORMATION
Some computers and serial port adapters support IRQ sharing. This is
common on Micro Channel Architecture (MCA) bus computers, such as IBM PS/2
computers, and Extended Industry Standard Architecture (EISA) bus
computers, provided the full EISA standard is implemented.
NOTE: IRQ sharing generally does not work when one of the devices is in
constant use (such as a serial mouse).
In Windows 3.x, it is possible to configure serial ports to use the same
IRQ (for example, COM1 and COM3 on IRQ 4, and COM2 and COM4 on IRQ 3) one
after the other, but not at the same time unless the serial adapter
supports IRQ sharing. Windows 3.1 and Windows for Workgroups 3.1x support
IRQ sharing for serial adapters. To use the adapters properly, make sure
that the IRQ values are set correctly. To do so, follow these steps:
- Double-click Control Panel in Program Manager, and then double-
click Ports.
- Double-click the port you want to configure, and then click Advanced.
- In the Interrupt Request Line (IRQ) box, click the correct interrupt.
- Click OK, click OK, and then click Close.
- Use any text editor (such as Notepad) to open the System.ini file in
the Windows folder.
- Add the following line to the [386Enh] section of the System.ini file:
COMIrqSharing=True
- Save and then close the System.ini file.
- Restart your computer.
For more information about the "COMIrqSharing=" setting and other switches
in the System.ini file for Windows 3.1 and Windows for Workgroups 3.1x,
please see the Sysini.wri file in the Windows folder.
For more information about the "COMIrqSharing=" setting for Windows 95,
please see the following article in the Microsoft Knowledge Base:
130533
Using Previous Windows Communications Switches in Windows
95
In Windows 95, after you install a modem, the serial port that the modem
is configured to use may not be listed in Device Manager. To determine
which serial port the modem is configured to use, click the modem in
Device Manager, and then click Properties.
The serial ports of Plug and Play modems do not appear in Device Manager
in the Ports section as you might expect. To view the modem's resources,
click the modem in Device Manager and then click Properties.
Modification Type: | Major | Last Reviewed: | 12/16/2000 |
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Keywords: | KB82545 |
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