"The System Cannot Find the Path Specified" error message occurs after you extend a clustered volume and then move it to another cluster node (819963)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition

Windows SE:46248Windows Bugs:789752n/a:SRX030429601003

SYMPTOMS

When you use Diskpart to extend a clustered volume on a Windows Server 2003-based computer that is running the Cluster service and then move the volume to another node in the group, you cannot access the volume. When you try to view the contents of the volume by using the volume's drive letter, you receive the following error message:
The system cannot find the path specified.
If you move the volume back to the original node, you can see the volume in Cluster Administrator, but when you try to access the contents of the volume, you receive the same error message.

CAUSE

When a volume is moved after Diskpart has been run, the volume path information that includes the drive letter mapping for the volume is lost.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------------
   20-May-2003  16:54  5.2.3790.33    444,928  Clusres.dll      
   09-May-2003  05:07                     211  Branches.inf
   20-May-2003  18:27                  10,095  Kb819963.cat
   20-May-2003  16:56                     354  Updatebr.inf
   20-May-2003  16:56                   5,932  Update_rtmqfe.inf

WORKAROUND

To prevent this problem from occurring, take the extended volume offline after you run Diskpart, and then bring the volume back online before you move it to another node. This refreshes the cluster registry with the new partition information.

Warning Do not take the cluster quorum disk offline.

If a volume has already lost its drive letter, as described in the "Symptoms" section of this article, you must delete the volume and then re-create it. All data on the volume is lost.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information about clusters on Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:

278007 Available features in Windows Server 2003 clusters


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kberrmsg kbfix kbbug KB819963 kbAudITPRO