SYMPTOMS
When you subscribe to a set of search results in SharePoint Portal Server, you may receive an error message that is similar to the following error message after you click
OK on the
New Subscription page:
Subscriptions to this item is not supported.
Failed to create subscription.
Error Number: -2147208954 (0x80043106)
Error Description: The subscription could not be created due to a failure in the Persistent Query Engine. Check the query syntax.
Error Source: Error Context/Call Stack: Failed to create subscription
As a result, you cannot subscribe to the search results.
CAUSE
This problem may occur if both of the following conditions are true:
- You create a document profile that contains a property that uses the Date property type, and then you apply the document profile to documents in the SharePoint Portal Server workspace.
-AND- - You search for documents that contain the property.
In this situation, SharePoint Portal Server incorrectly processes the subscription when you subscribe to search results that contain the property.
RESOLUTION
This problem was first fixed in a hotfix that is now contained in a service pack. If you have installed SharePoint Portal Server 2001 Service Pack 3 or a later service pack, you do not have to apply the hotfix.
Service pack information
This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.
To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
312963 How to obtain the latest SharePoint Portal Server 2001 service pack
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
----------------------------------------------------------------
16-May-2003 15:49 2,091,863 Defaultworkspace.cab
16-May-2003 11:41 327,345 Defaultworkspace.xml
30-Apr-2003 11:01 70 Install.cmd
17-Jun-1998 18:28 6.0.0.8169 32,768 Regtool5.dll
01-May-2003 17:13 1.0.0.0 32,768 Spsse758.exe
Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 2 (SP2).