Delivery status notification messages in Exchange 2000 Server do not appear correctly for some recipients after you configure the SMTP virtual server to use the French language (819831)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you configure the LanguageID entry of the Simple Mail Transfer Protocol (SMTP) virtual server instance to use the French-language code page, when Microsoft Exchange 2000 Server sends a delivery status notification message such as a non-delivery report (NDR) or a delivery report, the text in the delivery status notification message may not appear correctly for some recipients.

CAUSE

This problem occurs because the Exchange 2000 Server component Phatq.dll generates delivery status notification messages that are encoded in the Unicode UTF-7 character set. Because some client programs or Web-based messaging systems cannot decode the Unicode UTF-7 character set, the delivery status notification message does not appear correctly for that recipient.

RESOLUTION

Cumulative rollup information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824282 September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

File information

Component: Message Categorizer

The English version of this fix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
--------------------------------------------------------------
16-May-2003  20:50  6.0.6466.0        507,904  Phatq.dll

After you install the hotfix

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you install the hotfix that is described in this article, you must modify the DSNCodepage value in the Windows registry. Modify the DSNCodepage value to enable Exchange 2000 Server to encode existing languages under different character sets. To do so, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMTPSVC\Queuing

    If the Queuing key does not exist, create it. To do so, follow these steps:
    1. Right-click SMTPSVC, point to New, and then click Key.
    2. Name the new key Queuing.
  3. Right-click Queuing, point to New, and then click DWORD Value.
  4. Name the new value DSNCodepage.
  5. Right-click DSNCodepage, and then click Modify.
  6. In the Value data box, type the code page value that you want to assign to DSNCodepage. For example, type 000004e4, and then click OK.

    Note 000004e4 hexadecimal corresponds to 1252 decimal (Latin I (Windows 1252)).
  7. Right-click Queuing, point to New, and then click String Value.
  8. Name the new value DSNCharset.
  9. Right-click DSNCharset, and then click Modify.
  10. In the Value data box, type the character set that you want to assign to DSNCharset, and then click OK. For example, type iso-8859-1.

    Note ISO-8859-1 corresponds to Western European (ISO-8859-1).
  11. Quit Registry Editor.
If you change the language settings of the Delivery Status Notification (DSN) to English, the POP3 client that cannot decode the Unicode UTF-7 character set will be able to read the DSN.

To change the language settings of the Delivery Status Notification (DSN) to English, follow these steps:
  1. Stop the SMTP service on the computer that is running Exchange 2000 Server.
  2. At a command prompt, run the following command:

    cscript.exe c:\inetpub\adminscripts\adsutil.vbs set smtpsvc/SmtpDSNLanguageID 1033

    Note For this command, we assume that Microsoft Windows 2000 Server is installed on drive C.
  3. Restart the SMTP service.
Note To set the DSN language settings back to their original settings, follow these steps:
  1. Stop the SMTP service on the computer that is running Exchange 2000 Server.
  2. At a command prompt, run the following command:

    cscript.exe c:\inetpub\adminscripts\adsutil.vbs set smtpsvc/SmtpDSNLanguageID 1036

    Note For this command, we assume that Microsoft Windows 2000 Server is installed on drive C.
  3. Restart the SMTP service.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The DSNCharset registry value is a string value that indicates the character set that Exchange 2000 Server stamps the delivery status notification message as. The DSNCodepage registry value contains a DWORD value that determines the code page that Exchange 2000 Server tries to convert the Unicode to. These registry changes only permit Exchange Server to encode existing languages under different character sets. These registry changes do not add additional language support to Exchange Server. If you specify an unsupported character set and code page, the delivery status notification that is generated does not appear correctly.

For more information about how to edit the LanguageID entry of the SMTP virtual server, click the following article number to view the article in the Microsoft Knowledge Base:

286292 Exchange 2000 Server generates Japanese DSN (UTF-7) message

Note In this Microsoft Knowledge Base article, a smtpdsnlanguageid value of 1033 (English) is used. The smtpdsnlanguageid value for the French language is 1036.

Modification Type:MinorLast Reviewed:10/3/2005
Keywords:kbHotfixServer kbQFE kbQFE kbfix kbExchange2000preSP4fix kbbug KB819831 kbAudITPRO