Event IDs 5788 and 5789 are logged when you join a Windows 2000-based client to a Windows 2000 domain (819411)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

SYMPTOMS

Immediately after you join a Microsoft Windows 2000-based client computer to a Windows 2000 domain, the following event ID messages may be logged in the system log of the client computer:Type: Error
Event ID: 5789
Source: NETLOGON
Description:
Attempt to update DNS Host Name of the computer object in Active Directory failed. The updated value was 'Fully_Qualified_Domain_Name'. The following error occurred: %%2148074290Type: Error
Event ID: 5788
Source: NETLOGON
Description:
Attempt to update HOST Service Principal Names (SPNs) of the computer object in Active Directory failed. The updated values were '<UNAVAILABLE>' and '<UNAVAILABLE>'. The following error occurred: %%2148074290

CAUSE

This behavior occurs because the new computer name is not available to the domain. You must restart your computer after you join a client to the domain. After you restart your computer the dNSHostName attribute and the servicePrincipalName attribute are registered in the Active Directory directory service.

MORE INFORMATION

You can ignore the 5788 and 5789 event ID messages that are logged immediately after you join a Windows 2000 domain.

If you continue to receive these event ID messages, confirm that Domain Name System (DNS) is configured correctly. Also, make sure that there are no permissions issues or disjoint namespace issues.

For additional information about how to resolve permissions issues and disjoint namespace issues, click the following article numbers to view the articles in the Microsoft Knowledge Base:

257734 Event ID 5788 and event ID 5789 appear in the system event log

258503 DNS registration errors 5788 and 5789 when DNS domain and Active Directory domain name differ


Modification Type:MajorLast Reviewed:6/18/2004
Keywords:kbprb KB819411 kbAudITPRO