OL2002: Keyboard Language Changes to a Different Language When You Start Microsoft Outlook (819103)



The information in this article applies to:

  • Microsoft Outlook 2002, when used with:
    • the operating system: Microsoft Windows 2000

SYMPTOMS

When you start Microsoft Outlook, the keyboard layout changes to a different language.

For example, when you set the default keyboard to German (Germany), and then you start Outlook, the keyboard layout on the Language toolbar changes to English (United States).

CAUSE

This problem occurs when you have the Arabic or Hebrew Multilingual User Interface (MUI) components installed.

RESOLUTION

Service Pack Information

This problem is corrected in Office XP Service Pack 3.To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

307841 How to obtain the latest Office XP Service Pack

Hotfix Information

A supported fix is now available from Microsoft, but it is only intended to correct the problem described in this article. Only apply it to systems that are experiencing this specific problem. This fix may receive additional testing to further ensure product quality. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Office XP service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date           Time  Version    Size       File name     
   -------------------------------------------------------
   01-May-2003  22:28                  7,021,704  Outlookff.msp (Full-File patch)
   01-May-2003  20:08                  3,242,416  Outlookop.msp (Client patch)
				
After the hotfix is installed, the global version of this fix will have the file attributes (or later) that are listed in the following table.
   Date           Time  Version    Size       File name     
   -------------------------------------------------------
   2002-Dec-19	17:41	10.0.4817.0	109128	Envelope.dll  
   2003-Jan-09	15:31	10.0.4907.0	346696	Exsec32.dll
   2002-Aug-08	20:22	10.0.4406.0	137800	Impmail.dll
   2003-Feb-27	18:56	10.0.5025.0	543304	Outlcm.dll
   2003-Mar-14	00:55	10.0.5112.0	100936	Outlctl.dll
   2003-Apr-30	19:31	10.0.5229.0	6318664	Outllib.dll
   2002-Oct-11	15:14	10.0.4608.0	92744	Outlmime.dll
   2003-Apr-30	19:31	10.0.5229.0	47688	Outlook.exe
   2003-Mar-21	20:06	10.0.5119.0	121416	Outlph.dll
   2002-Nov-25	11:50	10.0.4721.0	47688	Recall.dll
				
This fix is a post-Office XP Service Pack 2 (SP-2) fix. To install the fix, you must have Office XP SP-2 installed. For additional information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:

325671 OFFXP: Overview of the Office XP Service Pack 2

Additionally, you may have to install Windows Installer 2.0 to install this fix. For additional information about the Windows Installer requirement for post-Office XP SP-2 fixes, click the following article number to see the article in the Microsoft Knowledge Base:

330537 OFFXP: Office XP Updates and Patches Released After September 2002 May Require Windows Installer 2.0


WORKAROUND

To work around this behavior, remove the Arabic or Hebrew MUI components. To do this, follow these steps:
  1. Quit all Microsoft Office programs.
  2. Click Start, point to Programs, point to Microsoft Office Tools, and then click Microsoft Office XP Language Settings.
  3. On the Enabled Languages tab, click either Arabic or Hebrew in the Enabled Languages list, and then click Remove. Repeat this step to remove the other enabled language, if it is installed.
  4. When you receive a message that states that the language settings have been updated, click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Office XP Service Pack 3.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbbug kbfix kbofficexppresp3fix KB819103