A program may run after the advertisement has expired (818985)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4
  • Microsoft Systems Management Server 2.0 SP5

SYMPTOMS

A Systems Management Server (SMS) program may unexpectedly run on an SMS client although the advertisement for the program has expired. This problem may occur if all the following conditions exist:
  • Two advertisements are scheduled to run on the client at the same time.
  • Both advertisements are mandatory.
  • Both advertisements have an expiration time.
  • The first advertisement runs past its expiration time. This problem may occur, for example, if the program encounters an error that stops the program, causing the program to run longer than expected.
When the first advertisement finishes running, the second advertisement runs although it has expired.

CAUSE

If Advertised Programs Manager has already scheduled a program to run, it does not check again to determine if the advertisement has expired before running the scheduled program. After you install the hotfix that this article describes, Advertised Programs Manager makes sure that the advertisement has not expired before running the program.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Systems Management Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix for SMS 2.0 Service Pack 5 (SP5) sites has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version        Size       File name            Platform
---------------------------------------------------------------------------
25-Feb-2003  16:50  2.0.92.10        383,472  Apasetup.exe         x86
25-Feb-2003  15:40  2.0.92.10      1,376,576  Ccmcore.exe          x86
25-Feb-2003  16:50                        67  Compverbase.ini      x86
25-Feb-2003  16:50                        67  Compversmsapm32.ini  x86
25-Feb-2003  16:50  2.0.1493.5131    257,904  Smsapm32.exe         x86
25-Feb-2003  15:40  2.0.1493.5116  3,495,758  Clicore.exe          x86
The German version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date          Time   Version             Size File name
------------------------------------------------------------------- 
26-Feb-2003   07:50  2.0.92.9         384,057  Apasetup.exe 
26-Feb-2003   06:40  2.0.92.9       1,376,841  Ccmcore.exe 
26-Feb-2003   06:40  2.0.1493.5116  3,764,008  Clicore.exe 
25-Feb-2003   07:50                        67  Compverbase.ini 
25-Feb-2003   07:50                        67  Compversmsapm32.ini 
23-Feb-2003   02:05  2.0.1493.5011    855,312  Preinst.exe 
25-Feb-2003   07:50  2.0.1493.5131    257,904  Smsapm32.exe

Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

Using the Hotfix Installer

Note This method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the Sms2.0-kb818985-spX-x86-enu.exe hotfix file (where X is the service pack version) and platform folders to the new folder. The folder structure must be such that the update file is located one folder "above" the platform folders.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console if it is running.
  5. Run Sms2.0-kb818985-spX-x86-enu.exe, and then follow the instructions in the wizard.

Performing a Manual Installation

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the platform folders that contain the hotfix files to the folder that you created.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console if it is running.
  5. Stop all SMS services.
  6. Replace the Smsapm32.exe file in the SmsRootFolder\Bin\Platform folder with the version from the hotfix.
  7. Replace the Apasetup.exe file in the SmsRootFolder\Inboxes\Clicomp.src\Smsapm32\Platform folder with the version from the hotfix.
  8. Replace the Ccmcore.exe and the Clicore.exe files in the SmsRootFolder\Inboxes\Clicomp.src\Base\Platform folder with the versions from the hotfix.
  9. Replace the Compver.ini file in the SmsRootFolder\Inboxes\Clicomp.src\Smsapm32 folder with the Compversmsapm32.ini file from the hotfix. Note that you must rename the Compversmsapm32.ini file to Compver.ini.
  10. Replace the Compver.ini file in the SmsRootFolder\Inboxes\Clicomp.src\Base folder with the Compverbase.ini file from the hotfix. Note that you must rename the Compverbase.ini file to Compver.ini.
  11. Restart the SMS Services

WORKAROUND

If it is critical that an advertisement does not run past its expiration time, avoid setting the mandatory time to be the same as other active advertisements. Also, before you distribute the program, test each advertisement to make sure that it runs as expected and that it does not encounter an error that prevents the program from finishing in its time window.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP6fix kbfix kbBug KB818985